Hardware and Software Requirements for Version 5.2

Print Friendly and PDF Follow

The following hardware and software are needed to run the Aeon system effectively. They are not provided as part of the licensing of Aeon or as part of the service contract with Atlas Systems.

These requirements ensure that Aeon will perform well for you and have all the necessary features available to support functionality. While Aeon may run in unsupported environments with older software and hardware, we cannot guarantee operation.

Client Requirements

The following hardware and software are compatible with the Aeon client:

Processor
  • 1 gigahertz (GHz) or faster processor or System on a Chip (SoC)
RAM

More RAM will increase system performance.

  • 2GB of RAM (minimum)
Hard Drive
  • 18 GB of free hard drive space (recommended)
  • 5 GB of free hard drive space (minimum)
Display
  • 1280x1024 resolution or larger (recommended)
  • 1024x768 resolution (required to view certain forms properly)
Printer
  • Access to printer
Internet
  • Microsoft Edge (minimum)
Windows
  • Windows 11
  • Windows 10 (minimum)
Microsoft .NET
  • Microsoft .NET Framework 4.6.2 (minimum)
Microsoft Office

32-bit or 64-bit can be used.

  • Microsoft Word and Excel 2021
  • Microsoft Word and Excel 2019
  • Microsoft Word and Excel 2016
  • Microsoft Word and Excel 2013 (minimum)

Server Requirements

You can install Windows on a physical server or virtual server as long as it meets the hardware and software requirements.

The following hardware and software are compatible with the Aeon server:

Processor
  • Intel Xeon 3Ghz processor or higher (recommended)
  • Intel Pentium 4 2Ghz processor (minimum)
RAM

More RAM will substantially increase system performance.

  • 8 GB of RAM (recommended)
  • 4 GB of RAM (minimum)
Hard Drive
  • 72 GB high-speed hard drive (recommended)
  • 36 GB hard drive (minimum)
Backup
  • Compatible backup device
Microsoft .NET
  • Microsoft .NET 4.6.2 Framework or higher full version
  • Microsoft .NET Core 2.2 or higher
  • Microsoft ASP.NET Core 2.2 Runtime bundle (Download from Microsoft's website)

    The ASP.NET Core 2.2 Runtime bundle must be installed to use the Aeon API.
Windows Server
  • Windows Server 2022 (Desktop Experience only)
  • Windows Server 2019 (Desktop Experience only)
  • Windows Server 2016 (Desktop Experience only) (minimum)
The IIS 6 Management Console component must be installed on Aeon Servers using Windows Server 2022 prior to performing the Aeon 5.2 server upgrade due to a known issue affecting PowerShell. For installation instructions, see Installing Required Windows Server 2022 Components for the Aeon 5.2 Update
SQL Server

SQL Express is not a supported database system.

  • Microsoft SQL Server 2022
  • Microsoft SQL Server 2019
  • Microsoft SQL Server 2017
  • Microsoft SQL Server 2016 Service Pack 2
  • Microsoft SQL Server 2014 Service Pack 3
  • Microsoft SQL Server 2012 Service Pack 4 (minimum)

SQL Server must be configured to use Mixed Mode authentication.

IIS
  • Internet Information Services 7.5 or later
IIS Manager must be installed to use the Aeon server installation/update PowerShell scripts.
SMTP
  • External SMTP server for sending emails

Questions?

If this article didn’t resolve your issue, please contact Atlas Support for assistance:

Contact Support