New DOCLINE scripts for ILLiad are now available - Action required prior to January 1st, 2020

As of January 1st, 2020, the old DOCLINE web address is being decommissioned. To ensure continued service to DOCLINE, please update to ILLiad 9.1 or replace your DOCLINE lua scripts with the latest version (v3.2.0.1) BEFORE January.

You can read DOCLINE's announcement here: https://news.nnlm.gov/ndco/2019/08/docline-6-web-address-changing-august-12th/

What's in the New DOCLINE Scripts?

  • The DOCLINE scripts (v3.2.0.1) have been updated to use the new DOCLINE URL https://docline.gov
  • Added support for handling requests placed using the "Place Requests - PMIDs" borrowing option. If the request is placed through the DOCLINE web interface, the lending library will receive a separate transaction number for each item requested. Since each DOCLINE request must be associated with a single ILLiad request, multiple borrowing requests using the Place Requests - PMID is not supported.
  • Removed the DOCLINE username and password customization keys since DOCLINE 6.0 no longer allows for automatic authentication into the website and requires each user to have a unique username and password.
  • Fixed issue where the default shipping option value for articles in Docline is being set to the default shipping value of loans. When the lending library imports the lending request, it imports the LenderAddresses. The DefaultShippingMethodLoan value was being placed into the Transactions.ShippingOptions field instead of using the LenderAddresses.DefaultShippingMethodArticle value. Bug# 4028

Updating the DOCLINE Scripts

For users updating to ILLiad 9.1:

ILLiad 9.1 is now available and new DOCLINE scripts will be automatically installed during the 9.1 update to support the DOCLINE URL change along with other features and bug fixes. Please review the Release Notes and FAQ for more information on the release. Atlas staff will be offering online training and pre-conference events to help you implement 9.1’s new features throughout 2020. To receive updates regarding these events, please subscribe to our newsletter.

For ILLiad 9.0.x.x users who are not updating until after January 1st, 2020:

Updating to ILLiad 9.1 is not required for continued DOCLINE integration, but ILLiad 9.0.x.x users will need to update to the new scripts BEFORE January 1st, 2020, for continued functionality. ILLiad 9.0.x.x users should download these new scripts (v3.2.0.1) and replace their existing set before DOCLINE’s URL change, scheduled for January 1st, 2020. The scripts will need to be updated on each computer that uses DOCLINE. See DOCLINE Configuration for instructions on manually replacing the .lua scripts. If you prefer, there is also a video on replacing the scripts here.

0

Comments

0 comments

Please sign in to leave a comment.

Didn't find what you were looking for?

New post