Addons

We're on ILLiad 8.6.1. Amazon and Google search addons were apparently default at one time, but after installing the ILLiad client on new Windows 10 PCs recently the addons are not active. In trying to activate the addons in Manage Addons, I receive error messages that access is denied to localsettings.xml and config.xml. In File Explorer, I've given my trusted installer Windows user full control to the folder C:\Program Files\ILLiad\Addons, but still no love. I have adjusted the Windows File Explorer setting to view hidden files, but there is no localsettings.xml.

If anyone has been down this twisted bumpy muddy and highwayman-lousy road before, can I get some pointers from you?

 

Thanks,

Melissa

mbrenneman@knoxlib.org

865-215-8795

0

Comments

5 comments
  • Official comment

    Hello Melissa,  I'm going to create a support ticket for you and one of our analysts will be in touch.  

    Comment actions Permalink
  •  

    This is what happens when I try to remove the Read-only attribute on the folder and provide my local admin Windows user credentials (Windows is logged in as interlibrary loan staff user who is not local admin).

    0
    Comment actions Permalink
  • Hello Melissa

    This sounds like an issue with the permissions on that computer. You will need to have someone to log on to the machine with credentials that have admin privileges and activate the Addon with the Manage Addons option from the system ribbon in the Client (see https://prometheus.atlas-sys.com/display/ILLiadAddons/Managing+Addon+Settings).

    Once the configurations have been updated on that machine through the Client, the Addon will be active and the user will not need admin privileges in order to use it. 

    Hopefully that will help you get a bit further down the bumpy road.

    0
    Comment actions Permalink
  • 0
    Comment actions Permalink
  • In "Properties" on the Addons folder, choose the "Security" tab then the "Edit" button.  Select the Users group and give Full Control. I had tried giving myself full control, as noted in my original post, but it didn't work. I'm still unclear what the difference was. At any rate, now it's okay. Thanks for the support, Atlas.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post