Server Hardware and Software Requirements for Version 4.5

Follow

The following hardware and software items are needed to run the server portion of the Ares system effectively. They are not provided as part of the licensing of Ares or as part of the service contract with Atlas Systems.

Server Configuration

These requirements ensure that Ares will perform well for you and have all the necessary features available to support functionality. While Ares may run in unsupported environments with older than the minimum required software and hardware, we cannot guarantee operation.

Hardware - Optimum Configuration

  • Intel Xeon 3Ghz or greater processor
  • 8GB of RAM
  • 72GB high speed hard drive
  • Ethernet connectivity to the internet/intranet
  • Compatible backup device

Software - Optimum Configuration

  • Windows Server 2008 R2, 2012, or 2012 R2
  • Internet Information Services 7.5 or 8.0
  • Microsoft SQL Server2008 R2, 2012, 2014 or 2016
    SQL Server must be configured to use Mixed Mode authentication. SQL Express is not a supported database system.
  • Microsoft SSRS (SQL Server Reporting Services)
  • External SMTP server for sending emails
  • Microsoft .NET 4.5 Framework full version

Hardware - Minimum Requirements

  • Intel Pentium 4 2Ghz or greater processor
  • 2GB of RAM minimum. More RAM will substantially increase system performance.
  • 36GB hard drive
  • Ethernet connectivity to the internet/intranet
  • Compatible backup device

Software - Minimum Requirements

  • Windows Server 2008 R2 using Internet Information Services 7.5
  • Microsoft SQL Server 2008. SQL Server must be configured to use Mixed Mode authentication. SQL Express is not a supported database system.
  • Microsoft SSRS (SQL Server Reporting Services)
  • External SMTP server for sending emails
  • Microsoft .NET 4.5 Framework full version
You can install Windows on a physical server or virtual server as long as it meets the hardware and software requirements.
 

IIS Requirements

In addition to having the Microsoft .NET 4.5.1 Framework installed on your webserver, you will need to ensure that IIS is properly set up to use the .NET Framework. If using IIS7 and higher, IIS must be configured with IIS6 Metabase compatibility enabled for proper installation.

Questions?

If this article didn’t resolve your issue, please take a moment and answer a few questions to help improve our documentation:

Feedback